登陆

CLI示例(V2R10版别)-VLAN透传形式「RU+千兆中心胖AP+L3+出口网关」

admin 2019-12-14 183人围观 ,发现0个评论

CLI示例(V2R10版别):VLAN透传形式【RU+千兆中心胖AP+L3+出口网关】

适用于:V200R010版别的千兆中心胖AP(AD9430DN-24和AD9430DN-12)。本文以AD9430DN-12(胖形式)设备为例。

事务需求

企业有出口网关【AR】、会聚交流机(L3)、千兆中心胖AP(配套RU),期望能够布置无线网络,为职工供给无线上网服务。

组网规划

RU办理:VLAN 100,网段为192.168.100.0/24。

无线事务:VLAN 3,SSID为“employee”,暗码为“huawei@123”,网段为192.168.3.0/24。网关为会聚交流机上的VLANIF3接口IP。

中心胖AP与会聚交流机三层互联的接口:VLANIF2。网段为192.168.2.0/24。

会聚交流机与出口网关三层互联的接口:VLANIF10。网段为192.168.10.0/24。

DHCP布置办法:

中心胖AP作为RU的DHCP服务器。

会聚交流机作为STA的DHCP服务器。

拓扑简图

操作过程

一、装备中心胖AP

1. 装备RU上线及事务VLAN

(1)装备与RU二层互通

system-view //先从用户视图切换到体系视图再进行装备

[CAP] vlan batch 100 3 //创立规划好的办理VLAN和事务VLAN

[CAP] interface gigabitethernet 0/0/0 //进入衔接RU的物理接口

[CAP-GigabitEthernet0/0/0] port link-type access //将接口的链路类型设置为access

[CAP-GigabitEthernet0/0/0] port default vlan 100 //指定接口的缺省VLAN为办理VLAN

[CAP-GigabitEthernet0/0/0] quit

(2)装备DHCP服务器(为RU分配IP)

[CAP] dhcp enable //翻开DHCP总开关

[CAP] interface vlanif 100 //创立办理VLAN的接口

[CAP-VlaCLI示例(V2R10版别)-VLAN透传形式「RU+千兆中心胖AP+L3+出口网关」nif100] ip address 192.168.100.1 255.255.255.0 //装备IP地址

[CAP-Vlanif100] dhcp select interface //启用接口地址池办法的DHCP服务器功用

[CAP-Vlanif100] quit

(3)指定RU的办理VLAN

[CAP] management-vlan 100

(4)装备RU的上线办法

[CAP] wlan //进入WLAN视图

[CAP-wlan-view] ap auth-mode no-auth //指定RU认证形式为不认证

[CAP-wlan-view] quit

阐明: 将RU上电后,当执行命令display ap all查看到RU的“State”字段为“nor”时,表明RU正常上线。示例如下

[CAP] display ap all

2. 装备WLAN事务

(1)装备VAP模板(employee)

[CAP] wlan //进入WLAN视图

[CAP-wlan-view] security-profile name employee //创立名为“employee”的安全模板

[CAP-wlan-sec-prof-employee] security wpa2 psk pass-phrase huawei@123 aes //装备无线暗码

[CAP-wlan-sec-prof-employee] quit

[CAP-wlan-view] ssid-profile name employee //创立名为“employee”的SSID模板

[CAP-wlan-ssid-prof-employee] ssid employee //指定SSID为“employee”

[CAP-wlan-ssid-prof-employee] quit

[CAPCLI示例(V2R10版别)-VLAN透传形式「RU+千兆中心胖AP+L3+出口网关」-wlan-view] vap-profile name employee //创立名为“employee”的VAP模板

[CAP-wlan-vap-prof-employee] security-CLI示例(V2R10版别)-VLAN透传形式「RU+千兆中心胖AP+L3+出口网关」profile employee //引证安全模板

[CAP-wlan-vap-prof-employee] ssid-profile employee //引证SSID模板

[CAP-wlan-vap-prof-employee] service-vlan vlan-id 3 //指定VAP对应的事务VLAN

[CAP-wlan-vap-prof-employee] quit

(2)装备VAP

阐明:前面没有装备RU参加独自的AP组,RU会主动参加到名为“default”的AP组中,因而装备默许的AP组“default”引证VAP模板即可。

[CAP-wlan-view] ap-group name default

[CAP-wlan-ap-group-default] vap-profile employee wlan 1 radio all

[CAP-wlan-ap-group-default] quit

[CAP-wlan-view] quit

3. 装备与会聚交流机互联(用于长途办理中心胖AP和透传事务VLAN)

[CAP] vlan batch 2 //创立规划好的互联VLAN

[CAP] interface gigabitethernet 0/0/12 //进入衔接会聚交流机的物理接口

[CAP-GigabitEthernet0/0/12] port link-type trunk //将接口的链路类型设置为trunk

[CAP-GigabitEt慕容晓晓hernet0/0/12] port trunk allow-pass vlan 2 3 //答应互联VLAN和事务VLAN经过

[CAP-GigabitEthernet0/0/12] quit

[CAP]] interface vlanif 2 //创立互联VLAN的接口

[CAP-Vlanif2] ip address 192.168.2.2 255.255.255.0 //装备IP地址

[CAP-Vlanif2] quit

[CAP] ip route-static 0.0.0.0 0.0.0.0 192.168.2.1 //装备默许路由,下一跳(192.168.2.1)是互联的对端设备上的接口IP

[CAP] return

二、装备会聚交流机(L3)

1. 装备与中心胖AP互联

(1)透传互联VLAN和事务VLAN

system-view //先从用户视图切换到体系视图再进行装备

[L3] vlan batch 2 3 //创立规划好的互联VLAN和事务VLAN

[L3] interface gigabitethernet 0/0/2 //进入衔接中心胖AP的物理接口

[L3-GigabitEthernet0/0/2] port link-type trunk //将接口的链路类型设置为trunk

[L3-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3 //答应互联VLAN和事务VLAN经过

[L3-GigabitEthernet0/0/2] quit

(2)装备互联接口和DHCP服务器(为STA分配IP)

[L3] interface vlanif 2 //创立互联VLAN的接口

[L3-Vlanif2] ip address 192.168.2.1 255.255.255.0 //装备IP地址

[L3-Vlanif2] quit

[L3] dhcp enable //翻开DHCP总开关

[L3] interface vlanif 3 //创立事务VLAN的接口

[L3-Vlanif3] ip address 192.168.3.1 255.255.255.0 //装备IP地址

[L3-Vlanif3] dhcp select interface //启用接口地址池办法的DHCP服务器功用

[L3-Vlanif3] dhcp server dns-list 114.114.114.114 //装备用户上网时用到的DNS服务器地址

[L3-Vlanif3] quit

2. 装备与出口网关互联

[L3] vlan batch 10 //创立规划好的互联VLAN

[L3] interface gigabitethernet 0/0/1 //进入衔接出口网关的物理接口

[L3-GigabitEthernet0/0/1] port link-type access //将接口的链CLI示例(V2R10版别)-VLAN透传形式「RU+千兆中心胖AP+L3+出口网关」路类型设置为access

[L3-GigabitEthernet0/0/1] port default vlan 10 //指定接口的缺省VLAN为互联VLAN

[L3-GigabitEthernet0/0/1] quit

[L3] interface vlanif 10 //创立互联VLAN的接口

[L3-Vlanif10] ip address 192.168.10.2 255.255.255.0 //装备IP地址

[L3-Vlanif10] quit

[L3] ip route-static 0.0.0.0 0.0.0.0 192.168.10.1 //装备默许路由,下一跳(192.168.10.1)是互联的对端设备上的接口IP

[L3] return

三、装备出口网关(以AR路由器为例)

1. 装备AR的LAN侧(与会聚交流机互联)

(1)装备互联接口

假如运用的是二层接口(假设是FE1)与会聚交流机衔接,需要为其创立接口所属VLAN对应的VLANIF接口再装备IP。

system-view //先从用户视图切换到体系视图再进行装备

[AR] vlan batch 10CLI示例(V2R10版别)-VLAN透传形式「RU+千兆中心胖AP+L3+出口网关」 //创立规划好的互联VLAN

[AR] interface ethernet 0/0/1 //进入衔接会聚交流机的物理接口

[AR-Ethernet0/0/1] port link-type access //将接口的链路类型设置为access

[AR-Ethernet0/0/1] port default vlan 10 //指定接口的缺省VLAN为互联VLAN

[AR-Ethernet0/0/1] quit

[AR] interface vlanif 10 //进入互联VLAN的接口

[AR-Vlanif10] ip address 192.168.10.1 255.255.255.0 //装备IP地址

[AR-Vlanif10] quit

假如运用的是三层接口(假设是GE1口)与会聚交流机衔接,那么能够直接装备IP。

system-view //先从用户视图切换到体系视图再进行装备

[AR] interface gigabitethernet 0/0/1 //CLI示例(V2R10版别)-VLAN透传形式「RU+千兆中心胖AP+L3+出口网关」进入衔接会聚交流机的物理接口

[AR-GigabitEthernet0/0/1] ip address 192.168.10.1 255.255.255.0 //装备IP地址

[AR-GigabitEthernet0/0/1] quit

(2)装备到内网网段的路由

[AR] ip route-static 192.168.2.0 255.255.255.0 192.168.10.2 //下一跳(192.168.10.2)是互联的对端设备上的接口IP

[AR] ip route-static 192.168.3.0 255.255.255.0 192.168.10.2

[AR] return

2. 装备AR的WAN侧(接入互联网)

WAN侧与内网方面的装备没有直接关系,依据上网办法不同,能够参阅下面示例中的WAN侧装备部分:

路由器-AR装备静态IP上网示例

路由器-AR装备PPPoE拨号上网示例

路由器-AR装备DHCP上网示例

---------------------------------------------------------------------------------------------------------------------------------------------------------

【温馨提示】

当完结悉数装备而且测验没有问题后,则应该及时保存当时装备,避免重启后当时装备丢掉。常见设备保存当时装备的办法能够拜见下面的链接:

路由器-AR常见设备保存当时装备的办法

请关注微信公众号
微信二维码
不容错过
Powered By Z-BlogPHP